Документация
Нашли ошибку? Сообщите нам ...Комментировать: Преобразование формата PCAD в графические форматыРаспечатать: Преобразование формата PCAD в графические форматы

Преобразование формата PCAD в графические форматы


"Документация" - техническая информация по применению электронных компонентов, особенностях построения различных радиотехнических и электронных схем, а также документация по особенностям работы с инженерным программным обеспечением и нормативные документы (ГОСТ).


В настоящее время при разработке радиоэлектронных устройств используют пакеты инженерного проектирования, в том числе и, пожалуй, наиболее часто - PCAD различных версий. Один из основных этапов проектирования - разработка печатных плат. При их изготовлении промышленным способом, как правило, формат PCAD предварительно преобразуют в Gerber. Радиолюбителям же удобнее получить файл чертежа печатной платы в любом распространенном графическом формате. О том, как это сделать, рассказывает помещенная ниже статья.

Этой теме уже уделено немало внимания, достаточно указать на статьи [1-3]. Однако описанным способам преобразования свойственны некоторые особенности, связанные либо с недостаточно высоким качеством конечного продукта, либо со сравнительно большим числом этапов его получения.

Предлагаю рассмотреть еще три способа преобразования современного формата файлов PCAD 2002 в обычные графические форматы.

Первый основан на использовании пакета Adobe Acrobat 6.0 Standard. Полный пакет имеет объем в установленном виде около 200 Mb. Преимущество данного способа состоит в наличии только одной промежуточной ступени преобразования без необходимости ручного редактирования, причем ее результатом является файл формата .pdf, который сам по себе является одним из стандартов технической интернет-документации.

Adobe Acrobat 6.0 Standard совместим с версиями Windows 9x/2K/XP После установки пакета в обычной конфигурации в системе появляется принтер Adobe PDF. Перед использованием принтер необходимо настроить. Заходим в Панель управления - Принтеры и факсы, щелкаем правой кнопкой мыши на значке принтера Adobe PDF и в ниспадающем меню выбираем пункт Настройка печати... Окно настроек открывается на закладке Adobe PDF Settings. В области настроек Adobe PDF Conversion Settings в строке Default Settings (настройки по умолчанию) следует выбрать набор установок Standard (1), после чего входим в режим его редактирования, нажав на кнопку Edit (рис. 1).



Рис. 1

В новом окне в области File Options (свойства файла) проверяем совместимость с ранними версиями стандарта PDF - в строке Compability желательно оставить настройку по умолчанию: Acrobat 4.0 (PDF 1.3). В строке Resolution следует изменить значение разрешения на 600 dpi (рис. 2). Остальные параметры можно оставить по умолчанию, а внесенные изменения сохранить, нажав на кнопку Save As... и введя новое имя файла настроек, например, Standard my.joboptions. Строку Adobe PDF Security оставляем без изменений, поскольку рассмотрение параметров безопасности документов PDF - это, скорее, тема для отдельной статьи.



Рис. 2

В окне Adobe PDF Настройки печати проверяем наличие флагов View Adobe PDF results (автоматический просмотр созданного PDF-файла по окончании печати) и Prompt for Adobe PDF filename (запрос имени файла печати). Затем выбираем закладку Расположение и кнопку Дополнительно..., после чего становятся доступными для изменения дополнительные параметры документа PDF. В пункте Графика также устанавливаем качество печати 600 dpi и нажимаем на кнопку ОК (рис. 3). Нажатием на кнопку Применить подтверждаем сделанные изменения в окне Настройки печати и закрываем его.



Рис. 3

На этом настройку системного принтера можно считать законченной и рассмотреть непосредственно процесс преобразования форматов. Запустив, например, программу проектирования печатных плат РСВ из состава пакета PCAD 2002, создаем или открываем существующий файл рисунка печатной платы. В меню File выбираем пункт Print Setup... (настройка печати...). В открывшемся окне в строке Name (имя принтера...) останавливаемся на выборе принтера Adobe PDF. Закрыв окно нажатием на кнопку ОК, переходим к пункту Print... (печать...). После подготовки соответствующим образом процесса печати рисунка платы с использованием диалогового окна программы переходим к предварительному просмотру, для чего нажимаем на кнопку Print Preview. Если результаты устраивают, запускаем собственно печать нажатием на кнопку Print... в левом верхнем углу окна предварительного просмотра. При этом выводится стандартное окно запроса на сохранение файла, где следует выбрать путь и ввести имя файла печати. После этого нажатием на кнопку Сохранить выполняется печать в файл формата PDF.

Следующий этап преобразования - вызов самой программы Adobe Acrobat 6.0 Standard. Открыв с ее помощью созданный документ, входим в пункт меню Files - Save As... и в открывшемся диалоговом окне выбираем тип файла из доступных графических форматов JPG, JPG2000, PNG, TIFF, причем в каждом случае есть возможность выбрать необходимые настройки каждого формата посредством кнопки Settings... Например, для формата TIFF возможны методы сжатия черно-белых изображений, изображений в градациях серого и цветных, а также метод управления цветовым профилем.

Второй способ очень прост и в то же время обеспечивает высокое качество изображения. Он заключается в прямом захвате рисунка в выделенной области экрана из окна предварительного просмотра печати с помощью практически любого граббера. Одним из возможных вариантов является использование распространенной программы Snaglt (http://www.techsmith.com). На сегодня доступна версия 8.2 программы, однако прекрасно работает и пятая со всеми Windows 9x/2K/XR При выборе этого варианта также после подготовки рисунка к печати переходим к предварительному просмотру с помощью Print Preview. Запустив граббер (рассматриваем восьмую версию), выбираем в меню пункт Capture-Input и режим захвата области экрана Region (кстати, этот параметр устанавливается по умолчанию). В пункте меню Capture-Output следует отметить File и проверить наличие флага Preview Window.

Нажав на кнопку Capture, выделяем с помощью появившегося курсора нужную область рисунка. По окончании процесса захвата открывается окно просмотра, в котором и выполняем сохранение рисунка в нужном формате. Здесь доступны практически все распространенные типы графических файлов с настройкой соответствующих опций Для получения высокого качества следует выбирать глубину цвета не менее 24-bit и качество не ниже 75 (для JPG).

Третий способ также не содержит промежуточных этапов, позволяя сразу получить рисунок печатной платы в формате EMF. Соответствует ли этот тип файлов формату Windows Enhanced Metafile, сказать трудно, поскольку PCAD, как правило, отказывается воспринимать внешние файлы с таким расширением, однако файлы, созданные PCAD-PCB, прекрасно читаются в стандартном просмотрщике Windows Picture and Fax Viewer.

Для этого следует выделить необходимый фрагмент рисунка печатной платы прямо в рабочем окне PCAD, выбрать пункт меню Edit-CopytoFile... и в открывшемся окне тип файла PCAD-Pictures, *.emf. Получившееся цветное изображение обладает высоким качеством, однако при стандартных цветовых настройках PCAD возможно наличие полутоновых областей. Чтобы не прибегать к коррекции тонов в графическом редакторе, вероятно, понадобится подобрать палитру PCAD с помощью меню Options-Display (Background, Pad, Line и др.).

Кстати, аналогичным образом возможен и экспорт принципиальных схем из программы PCAD-Schematic из состава того же PCAD 2002 в формат *.wmf Windows Metafile. При стандартной палитре получается негативное полутоновое изображение, которое при желании также можно скорректировать через меню Options-Display (Background, Part, Wire и др.).

Указанные форматы без проблем импортируются также в Microsoft Word любых версий, а файл wmf просто конвертируется в другие форматы средствами Windows. Для этого в окне Picture and Fax Viewer, вызываемом по умолчанию для просмотра файлов рассматриваемого формата, необходимо щелкнуть правой кнопкой мыши и в открывшемся контекстном меню выбрать пункт Edit. При этом файл передается для редактирования прямо в программу Paint, хотя в списке поддерживаемых ею форматов wmf отсутствует!

Метафайлы Windows могут быть преобразованы в другие графические с помощью популярных просмотрщиков ACDSee и XNView (бесплатный), последние версии которых можно переписать, например, с сайта www.softodrom.ru.

В заключение можно коснуться вопроса обработки полученных изображений в мощном графическом редакторе Adobe Photoshop. Возможность работы со слоями печатных плат ничем не уступает популярному в этом смысле пакету CorelDraw. Практический интерес представляет также возможность зеркального отображения и свободной трансформации, реализуемые через пункты меню Edit - Transform и Free Transform. Например, придать рисунку готовой печатной платы элементарный наклон или усложнить геометрическую конфигурацию проще именно в процессе редактирования графического формата в Adobe Photoshop.

ЛИТЕРАТУРА

  1. Лузянин В. Преобразование файлов PCAD в другие форматы. - Радио, 2001, № 6, с. 30.
  2. Горячкин А., Грищенко А., Исаев А. Преобразование файлов P-CAD в графические форматы. - Радио, 2002, № 1, с. 24,
  3. Горячкин А. Распечатка файлов P-CAD 2001. - Радио, 2003, № 11, с. 28, 29.

Автор: Д.Панкратьев, г. Ташкент, Узбекистан


Дата публикации: 11.01.2008
Мнения читателей
  • Иван / 02.11.2012 - 22:24
    Перегоняю P-CAD-овские файлы довольно длинной цепочкой этапов, но зато получаю графику гигоскопических размеров. Использую BullZip PDF бесплатная печаталка, в свойствах печатаемого листа выбираю А0 формат, к печатаемому изображению применяю размер Fit To Page. Послечего нажимаю печать. Появляется окошко виртуального принтера с вариантами выбора форматов. Выбираю BMP. Сохраняю. Размер файла внушительный, порядка 120 МБ, открываю в IrfanWiev, сжимаю число цветов до 32-х или лучше 16-ти. При необходимости можно открыть и скорректировать палитру цветов до нужных полутонов. Выполняю автоматическую обрезку краёв, и теперь можно сохранить как Gif а лучше Png формат. В итоге растровый файл с разрешением не хуже векторного, по крайней мере даже при печати на больших листах пиксельность изображения не будет видна. Пример - http://s58.radikal.ru/i162/1211/b1/8a2b729eb9db.png
  • electrik / 25.10.2010 - 12:45
    Скажите пожалуйста, а где Вы покупаете электрооборудование? Мне посоветовали много интернет магазинов, но я не могу выбрать. Заранее всем спасибо за ответ, и извиняюсь если попал не в тему.
  • guest / 12.05.2008 - 07:43
    На PCAD свет клином не сошелся. Рекомендую Diptrace - замечательная САПР для печатных плат. притом бесплатна для учебных целей. А что еще надо студенту и преподу?))Альтернативы платным программам - бесплатное лицензионное программное обеспечение. Набор оптимального бесплатного и лицензионного софта для дома, учебы и офиса, различные дистрибутивы, подробные описания и скриншоты на сайте http://soft.mod-site.net

Вы можете оставить свой комментарий, мнение или вопрос по приведенному вышематериалу:








 



RadioRadar.net - datasheet, service manuals, схемы, электроника, компоненты, semiconductor,САПР, CAD, electronics